题面:Redundant Paths G

大秦为你打开题目传送门

题面翻译

为了从 $F(1 \le F \le 5000)$ 个草场中的一个走到另一个,贝茜和她的同伴们有时不得不路过一些她们讨厌的可怕的树.奶牛们已经厌倦了被迫走某一条路,所以她们想建一些新路,使每一对草场之间都会至少有两条相互分离的路径,这样她们就有多一些选择。

每对草场之间已经有至少一条路径.给出所有 $R\ (F-1 \le R \le 10000)$ 条双向路的描述,每条路连接了两个不同的草场,请计算最少的新建道路的数量,路径由若干道路首尾相连而成.两条路径相互分离,是指两条路径没有一条重合的道路.但是,两条分离的路径上可以有一些相同的草场.对于同一对草场之间,可能已经有两条不同的道路,你也可以在它们之间再建一条道路,作为另一条不同的道路。

题目描述

In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the rest of the herd are forced to cross near the Tree of Rotten Apples. The cows are now tired of often being forced to take a particular path and want to build some new paths so that they will always have a choice of at least two separate routes between any pair of fields. They currently have at least one route between each pair of fields and want to have at least two. Of course, they can only travel on Official Paths when they move from one field to another.

Given a description of the current set of R (F-1 <= R <= 10,000) paths that each connect exactly two different fields, determine the minimum number of new paths (each of which connects exactly two fields) that must be built so that there are at least two separate routes between any pair of fields. Routes are considered separate if they use none of the same paths, even if they visit the same intermediate field along the way.

There might already be more than one paths between the same pair of fields, and you may also build a new path that connects the same fields as some other path.

输入格式

Line 1: Two space-separated integers: F and R

Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.

输出格式

Line 1: A single integer that is the number of new paths that must be built.

样例 #1

样例输入 #1

1
2
3
4
5
6
7
8
7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7

样例输出 #1

1
2

提示

Explanation of the sample:

One visualization of the paths is:

Building new paths from 1 to 6 and from 4 to 7 satisfies the conditions.

Check some of the routes:

  • 1 – 2: 1 –> 2 and 1 –> 6 –> 5 –> 2
  • 1 – 4: 1 –> 2 –> 3 –> 4 and 1 –> 6 –> 5 –> 4
  • 3 – 7: 3 –> 4 –> 7 and 3 –> 2 –> 5 –> 7

Every pair of fields is, in fact, connected by two routes.

It’s possible that adding some other path will also solve the problem (like one from 6 to 7). Adding two paths, however, is the minimum.

思路

显然的,这题需要边双缩点(题目都快把边这个关键字砸你脸上了),然后的话,缩点之后,图变成了一棵树,而这样就说明我们如果要把它变成一个边双连通分量,我们要把所有度为 1 的点消掉,这样的话就都是环了。

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
#include<bits/stdc++.h>
using namespace std;

typedef long long ll;
// typedef __int128 int128;
typedef pair<int , int > pii;
typedef unsigned long long ull;

namespace FastIO
{
// char buf[1 << 20], *p1, *p2;
// #define getchar() (p1 == p2 && (p2 = (p1 = buf) + fread(buf, 1, 1 << 20, stdin), p1 == p2) ? EOF : *p1++)
template<typename T> inline T read(T& x) {
x = 0;
int f = 1;
char ch;
while (!isdigit(ch = getchar())) if (ch == '-') f = -1;
while (isdigit(ch)) x = (x << 1) + (x << 3) + (ch ^ 48), ch = getchar();
x *= f;
return x;
}
template<typename T, typename... Args> inline void read(T& x, Args &...x_) {
read(x);
read(x_...);
return;
}
inline ll read() {
ll x;
read(x);
return x;
}
};
using namespace FastIO;

const int MaxV = 5010;
const int MaxE = 10010;

template<int N, int M>
class Graph {
private :
struct Edge {
int to, nt, wt;
Edge() {}
Edge(int to, int nt, int wt) : to(to), nt(nt), wt(wt) {}
}e[M];
int hd[N], cnte;
public :
inline void clear() { memset(hd, 0, sizeof(hd)), cnte = 0; }
inline void AddEdge(int u, int v, int w = 0) {
e[++cnte] = Edge(v, hd[u], w);
hd[u] = cnte;
}
inline int head(int u) { return hd[u]; }
inline int nt(int u) { return e[u].nt; }
inline int to(int u) { return e[u].to; }
inline int wt(int u) { return e[u].wt; }
};

int n, m;
int uid[MaxE], vid[MaxE];
Graph< MaxV, MaxE << 1 >G;

inline void Input() {
read(n, m);
G.AddEdge(0, 0);
for(int i = 1; i <= m; i++) {
read(uid[i], vid[i]);
G.AddEdge(uid[i], vid[i]);
G.AddEdge(vid[i], uid[i]);
}
}

int dfn[MaxV], low[MaxV], cntd;
stack<int >st;
int cntc, col[MaxV];
int vise[MaxE << 1];

void Tarjan(int u, int fa) {
dfn[u] = low[u] = ++cntd; st.push(u);
for(int i = G.head(u); i; i = G.nt(i)) {
int v = G.to(i);
if(vise[i] || vise[i^1]) continue;
vise[i] = vise[i^1] = 1;
if(!dfn[v]) {
Tarjan(v, u);
low[u] = min(low[u], low[v]);
}
else if(v != fa && dfn[u] > dfn[v]) {
low[u] = min(low[u], dfn[v]);
}
}
if(dfn[u] == low[u]) {
cntc++;
int v;
do {
v = st.top(); st.pop();
col[v] = cntc;
}while(u != v);
}
}

int deg[MaxV];
map<pair<int , int >, int >mp;

inline void Work() {
for(int i = 1; i <= n; i++) {
if(!dfn[i]) {
Tarjan(i, i);
}
}
for(int i = 1; i <= m; i++) {
if(col[uid[i]] != col[vid[i]]) {
if(mp[make_pair(col[uid[i]], col[vid[i]])]) continue;
if(mp[make_pair(col[vid[i]], col[uid[i]])]) continue;
mp[make_pair(col[uid[i]], col[vid[i]])] = 1;
mp[make_pair(col[vid[i]], col[uid[i]])] = 1;
deg[col[uid[i]]]++;
deg[col[vid[i]]]++;
}
}
int ans = 0;
for(int i = 1; i <= cntc; i++) {
if(deg[i] == 1) {
ans++;
}
}
printf("%d\n", ans + 1 >> 1);
}

int main() {
int T = 1;
while(T--) {
Input();
Work();
}
return 0;
}