题面:[ZJOI2008] 树的统计

大秦为你打开题目传送门

题目描述

一棵树上有 $n$ 个节点,编号分别为 $1$ 到 $n$,每个节点都有一个权值 $w$。

我们将以下面的形式来要求你对这棵树完成一些操作:

I. CHANGE u t : 把结点 $u$ 的权值改为 $t$。

II. QMAX u v: 询问从点 $u$ 到点 $v$ 的路径上的节点的最大权值。

III. QSUM u v: 询问从点 $u$ 到点 $v$ 的路径上的节点的权值和。

注意:从点 $u$ 到点 $v$ 的路径上的节点包括 $u$ 和 $v$ 本身。

输入格式

输入文件的第一行为一个整数 $n$,表示节点的个数。

接下来 $n-1$ 行,每行 $2$ 个整数 $a$ 和 $b$,表示节点 $a$ 和节点 $b$ 之间有一条边相连。

接下来一行 $n$ 个整数,第 $i$ 个整数 $w_i$ 表示节点 $i$ 的权值。

接下来 $1$ 行,为一个整数 $q$,表示操作的总数。

接下来 $q$ 行,每行一个操作,以 CHANGE u t 或者 QMAX u v 或者 QSUM u v 的形式给出。

输出格式

对于每个 QMAX 或者 QSUM 的操作,每行输出一个整数表示要求输出的结果。

样例 #1

样例输入 #1

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
4
1 2
2 3
4 1
4 2 1 3
12
QMAX 3 4
QMAX 3 3
QMAX 3 2
QMAX 2 3
QSUM 3 4
QSUM 2 1
CHANGE 1 5
QMAX 3 4
CHANGE 3 6
QMAX 3 4
QMAX 2 4
QSUM 3 4

样例输出 #1

1
2
3
4
5
6
7
8
9
10
4
1
2
2
10
6
5
6
5
16

提示

对于 $100 \%$ 的数据,保证 $1\le n \le 3\times 10^4$,$0\le q\le 2\times 10^5$。

中途操作中保证每个节点的权值 $w$ 在 $-3\times 10^4$ 到 $3\times 10^4$ 之间。

思路

其实也是模板,不过要维护两个信息,一个最大值,一个加和。

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
#include<bits/stdc++.h>
using namespace std;

typedef long long ll;
// typedef __int128 int128;
typedef pair<int , int > pii;
typedef unsigned long long ull;

namespace FastIO
{
// char buf[1 << 20], *p1, *p2;
// #define getchar() (p1 == p2 && (p2 = (p1 = buf) + fread(buf, 1, 1 << 20, stdin), p1 == p2) ? EOF : *p1++)
template<typename T> inline T read(T& x) {
x = 0;
int f = 1;
char ch;
while (!isdigit(ch = getchar())) if (ch == '-') f = -1;
while (isdigit(ch)) x = (x << 1) + (x << 3) + (ch ^ 48), ch = getchar();
x *= f;
return x;
}
template<typename T, typename... Args> inline void read(T& x, Args &...x_) {
read(x);
read(x_...);
return;
}
inline ll read() {
ll x;
read(x);
return x;
}
};
using namespace FastIO;

struct Node {
// some basic viariables
ll sum, mx;
Node() { sum = 0; mx = -1e18; }
Node operator + (const Node& b) const {
Node ans;
ans.sum = sum + b.sum;
ans.mx = max(mx, b.mx);
return ans;
}
};
template<const int N>
class SegTree {
private:
Node node[N];
int lc[N], rc[N], cntn;
ll lazy[N];
public :
// clear function
void clear(int rt) {
if(!rt) return ;
lazy[rt] = 0, node[rt] = Node();
clear(lc[rt]);
clear(rc[rt]);
lc[rt] = rc[rt] = 0;
}
inline int newNode() {
cntn++;
lc[cntn] = rc[cntn] = lazy[cntn] = 0;
return cntn;
}
// AddOperation now nowl nowr addval
inline void Add(int rt, int l, int r, ll val) {
node[rt].sum = val;
node[rt].mx = val;
}
// PushDownOperation now nowl nowr
inline void PushDown(int rt, int l, int r) {
if(l == r || !lazy[rt]) return ;
int mid = (l + r) >> 1;
if(!lc[rt]) lc[rt] = newNode();
Add(lc[rt], l, mid, lazy[rt]);
if(!rc[rt]) rc[rt] = newNode();
Add(rc[rt], mid + 1, r, lazy[rt]);
lazy[rt] = 0;
}
// range Modify now nowl nowr qizl qizr addval
void Modify(int &rt, int l, int r, int L, int R, ll val) {
if(!rt) rt = newNode();
if(L <= l && r <= R) {
Add(rt, l, r, val);
return;
}
PushDown(rt, l, r);
int mid = (l + r) >> 1;
if(L <= mid) Modify(lc[rt], l, mid, L, R, val);
if(R > mid) Modify(rc[rt], mid + 1, r, L, R, val);
node[rt] = node[lc[rt]] + node[rc[rt]];
}
// range Query now nowl nowr qizl qizr
Node Query(int &rt, int l, int r, int L, int R) {
if(!rt) rt = newNode();
if(L <= l && r <= R) return node[rt];
PushDown(rt, l, r);
int mid = (l + r) >> 1;
Node res;
// set some basic value for res
res.sum = 0; res.mx = -1e18;
if(L <= mid) res = res + Query(lc[rt], l, mid, L, R);
if(R > mid) res = res + Query(rc[rt], mid + 1, r, L, R);
return res;
}
};

template<int N, int M>
class Graph {
private :
struct Edge {
int to, nt, wt;
Edge() {}
Edge(int to, int nt, int wt) : to(to), nt(nt), wt(wt) {}
}e[M];
int hd[N], cnte;
public :
inline void clear() { memset(hd, 0, sizeof(hd)), cnte = 0; }
inline void AddEdge(int u, int v, int w = 0) {
e[++cnte] = Edge(v, hd[u], w);
hd[u] = cnte;
}
inline int head(int u) { return hd[u]; }
inline int nt(int u) { return e[u].nt; }
inline int to(int u) { return e[u].to; }
inline int wt(int u) { return e[u].wt; }
};

const int MaxV = 3e4 + 10;
const int MaxE = 6e4 + 10;
const int MaxW = 6e4 + 10;

int n, Q;
Graph< MaxV, MaxE >G;
ll w[MaxV];

SegTree< MaxV << 5 >Tree; int rt;

inline void Input() {
read(n);
int u, v;
for(int i = 1; i < n; i++) {
read(u, v);
G.AddEdge(u, v);
G.AddEdge(v, u);
}
for(int i = 1; i <= n; i++) {
read(w[i]);
}
read(Q);
}

int fa[MaxV], dep[MaxV];
int sz[MaxV], son[MaxV];
int top[MaxV];
int id[MaxV], rk[MaxV], cntd;

void Dfs(int u, int F) {
fa[u] = F, dep[u] = dep[F] + 1, sz[u] = 1;
for(int i = G.head(u); i; i = G.nt(i)) {
int v = G.to(i);
if(v == F) continue;
Dfs(v, u);
sz[u] += sz[v];
if(sz[son[u]] < sz[v]) son[u] = v;
}
}

void Dfs2(int u, int tp) {
top[u] = tp;
id[u] = ++cntd;
rk[cntd] = u;
if(!son[u]) return ;
Dfs2(son[u], tp);
for(int i = G.head(u); i; i = G.nt(i)) {
int v = G.to(i);
if(v == son[u] || v == fa[u]) continue;
Dfs2(v, v);
}
}

inline void GetMax(int u, int v) {
ll ans = -1e18;
while(top[u] != top[v]) {
if(dep[top[u]] < dep[top[v]]) swap(u, v);
ans = max(ans, Tree.Query(rt, 1, n, id[top[u]], id[u]).mx);
u = fa[top[u]];
}
if(dep[u] > dep[v]) swap(u, v);
ans = max(ans, Tree.Query(rt, 1, n, id[u], id[v]).mx);
printf("%lld\n", ans);
}

inline void GetSum(int u, int v) {
ll sum = 0;
while(top[u] != top[v]) {
if(dep[top[u]] < dep[top[v]]) swap(u, v);
sum += Tree.Query(rt, 1, n, id[top[u]], id[u]).sum;
u = fa[top[u]];
}
if(dep[u] > dep[v]) swap(u, v);
sum += Tree.Query(rt, 1, n, id[u], id[v]).sum;
printf("%lld\n", sum);
}

inline void Work() {
Dfs(1, 1), Dfs2(1, 1);
for(int i = 1; i <= n; i++) {
Tree.Modify(rt, 1, n, id[i], id[i], w[i]);
}
char op[10]; int u, v;
while(Q--) {
scanf("%s%d%d", op, &u, &v);
if(op[0] == 'C') {
Tree.Modify(rt, 1, n, id[u], id[u], v);
}
else if(op[1] == 'M') {
GetMax(u, v);
}
else {
GetSum(u, v);
}
}
}

int main() {
int T = 1;
while(T--) {
Input();
Work();
}
return 0;
}